August 30, 2017 - REV 2.0

AROUSOR REV 2.0 IS CURRENTLY MAC ONLY COMPATIBLE

Windows 7 or higher compatibility coming within a couple months

 

To begin your FREE 14-DAY DEMO, click the "TRY" button when launching the AROUSOR for the first time.

If you've purchased the AROUSOR and have received your iLok License via email, please see below instructions for activating your AROUSOR.

REDEEMING YOUR iLOK LICENSE CODE

 

Before redeeming your iLok license for the AROUSOR™ make sure you are running the latest iLok License Manager. You can get more information about the iLok License Manager and find the latest installers at the following link: https://www.ilok.com/#!license-manager

 

STEP 1   Run the iLok License Manager and sign in to your iLok account.

 

STEP 2   Click the button in the upper right corner of the window illustrated below:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

STEP 3   Enter your Activation Code then click "Next"

 

STEP 4  Select your iLok 2 Dongle from the Activation Location dialog box and click "Activate"

 

STEP 5   You will receive a confirmation when the license is deposited to your iLok 2 Dongle.

 

 

SYSTEM REQUIREMENTS FOR AROUSOR™

 

WINDOWS

AROUSOR REV 2.0 IS CURRENTLY MAC ONLY COMPATIBLE

Windows 7 or higher compatibility coming within a couple months

Windows 7 or higher for Rev 1.0

iLok 2 USB key and PACE iLok License Manager (latest version downloadable here)

 

MAC

Mac OS X 10.7 or higher

iLok 2 USB key and PACE iLok License Manager (latest version downloadable here)

 

DAW COMPATIBILITY

32/64-bit AAX (OSX and Windows)

64-bit VST2 (OSX and Windows)

64-bit VST3 (OSX and Windows)

64-bit AU (OSX)

AAX system minimum requirements are Pro Tools 10.3.5 and OSX 10.7 or higher; Windows 7 or higher.

 

AU may function on earlier systems, but will only be qualified for and supported with system minimum requirements of OSX 10.7 or higher.

Logic 9 is the reference AU host used for testing and verification.

 

VST may function on earlier systems, but will only be qualified for and supported with system minimum requirements of OSX 10.7 or higher;

Windows 7 or higher.

 

Cubase 6 is the reference VST host used for testing and verification.

LEGACY INSTALLERS

Revert to an older Revision

JOIN THE ELI MAILING LIST

(We won't kill you with emails...just the good stuff.)

Clicking this button will send a

"confirmation email" to this email address.